天际说

Requires: libc.so.6(GLIBC_2.15)(64bit)错误

发布时间:2019年3月17日 / 分类:CentOS相关,运维经验 / 4,067 次围观 / 抢沙发!

使用

strings /lib64/libc.so.6 | grep GLIBC

列出系统安装的glibc版本:

[root@test /]# strings /lib64/libc.so.6 | grep GLIBC
GLIBC_2.2.5
GLIBC_2.2.6
GLIBC_2.3
GLIBC_2.3.2
GLIBC_2.3.3
GLIBC_2.3.4
GLIBC_2.4
GLIBC_2.5
GLIBC_2.6
GLIBC_2.7
GLIBC_2.8
GLIBC_2.9
GLIBC_2.10
GLIBC_2.11
GLIBC_2.12
GLIBC_PRIVATE

下载 glibc-2.15.tar.gz

wget http://ftp.gnu.org/gnu/glibc/glibc-2.15.tar.gz
tar xf glibc-2.15.tar.gz
cd glibc-2.15
mkdir build
cd build
../configure --prefix=/opt/glibc-2.15 --disable-profile --enable-add-ons --with-headers=/usr/include --with-binutils=/usr/bin
make && make install


标签:none